Page 1 of 1

Site Compatilibity

PostPosted: Tue Aug 13, 2013 8:09 am
by Hannah
If you would like to have the "full" Cyan forums experience, please use an up-to-date version of Google Chrome, Firefox, or Safari. IE 10 works fine as well, but we are currently working on some compatibility issues with IE and our images, as well as the site "wrap" not being recognized below IE 10.

This site is still considered to be in the "Beta" stage of release, so please understand that the site isn't perfect! ... Yet ;)